# fast-uri vulnerable to scheme injection via an unescaped first-segment colon in suffix references

Advisory record · `GHSA-333x-w4r6-6crp`

- **Identifiers:** `GHSA-333x-w4r6-6crp` · `CVE-2026-110725`
- **State:** Confirmed
- **Severity:** CVSS 3.7 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-41](https://cwe.mitre.org/data/definitions/41.html) · [CWE-116](https://cwe.mitre.org/data/definitions/116.html)
- **Tags:** [CWE-41](https://agentprime.io/advisories/tag/cwe-41.md) · [CWE-116](https://agentprime.io/advisories/tag/cwe-116.md)
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Oct 2026, 21:36 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `fast-uri` (npm): affected `<2.4.8 || >=3.0.0, <3.1.9 || >=4.0.0, <4.2.3`; fixed in `2.4.8`, `3.1.9`, `4.2.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.7 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0030, the 23rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-333x-w4r6-6crp)

## Sources

- [GitHub Advisory Database: GHSA-333x-w4r6-6crp](https://github.com/advisories/GHSA-333x-w4r6-6crp)
- [OSV: GHSA-333x-w4r6-6crp](https://osv.dev/vulnerability/GHSA-333x-w4r6-6crp)
- <https://github.com/fastify/fast-uri/security/advisories/GHSA-333x-w4r6-6crp>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-110725>
- <https://github.com/fastify/fast-uri/commit/39e6493c1356f30a0084171627eb266786e1620e>
- <https://github.com/fastify/fast-uri/commit/a9b8d67353630aab053cd727cf629023dd018d2b>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/fastify/fast-uri>
- <https://github.com/fastify/fast-uri/releases/tag/v2.4.8>
- <https://github.com/fastify/fast-uri/releases/tag/v3.1.9>
- <https://github.com/fastify/fast-uri/releases/tag/v4.2.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-333x-w4r6-6crp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-333x-w4r6-6crp/>. Everything for agents: <https://agentprime.io/llms.txt>.
