# 0xJacky/nginx-ui /api/nodes Leaks Cluster Node Tokens and Allows Cross-Node Impersonation as initUser

Advisory record · `GHSA-32gc-wf3m-78w9`

- **Identifiers:** `GHSA-32gc-wf3m-78w9` · `CVE-2026-107811` · `GO-2026-6702`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-862](https://cwe.mitre.org/data/definitions/862.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [Broken access control](https://agentprime.io/advisories/tag/access-control.md)
- **Published:** 9 Oct 2026
- **Updated:** 19 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Oct 2026, 17:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/0xJacky/Nginx-UI` (Go): affected `>=1.9.10-0.20250517140552-daee3ac7ade1, <1.9.10-0.20260728091109-0ecbd106c37b`; fixed in `1.9.10-0.20260728091109-0ecbd106c37b`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Nginx-UI (github.com/0xJacky/Nginx-UI) versions from 1.9.10-0.20250517140552-daee3ac7ade1 before 1.9.10-0.20260728091109-0ecbd106c37b expose cluster node tokens through the /api/nodes endpoints to any authenticated user. An attacker with a low-privileged account can read a node token and send it as the X-Node-Secret header to a remote node, which then treats the request as the initial administrator and allows actions such as system restart. Upgrade to 1.9.10-0.20260728091109-0ecbd106c37b or later; no workaround is listed.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0043, the 37th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-32gc-wf3m-78w9)

## Sources

- [GitHub Advisory Database: GHSA-32gc-wf3m-78w9](https://github.com/advisories/GHSA-32gc-wf3m-78w9)
- [OSV: GHSA-32gc-wf3m-78w9](https://osv.dev/vulnerability/GHSA-32gc-wf3m-78w9)
- <https://github.com/0xJacky/nginx-ui/security/advisories/GHSA-32gc-wf3m-78w9>
- <https://github.com/0xJacky/nginx-ui/commit/0ecbd106c37b5143be14880c9447a66135151512>
- <https://github.com/0xJacky/nginx-ui>
- <https://github.com/0xJacky/nginx-ui/releases/tag/v2.5.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-32gc-wf3m-78w9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-32gc-wf3m-78w9/>. Everything for agents: <https://agentprime.io/llms.txt>.
