# Ecto missing \`is_nil\` requirement

Advisory record · `GHSA-2xxx-fhc8-9qvq`

- **Identifiers:** `GHSA-2xxx-fhc8-9qvq` · `CVE-2017-20166`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-754](https://cwe.mitre.org/data/definitions/754.html)
- **Tags:** [CWE-754](https://agentprime.io/advisories/tag/cwe-754.md)
- **Published:** 12 Apr 2022
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 12 Apr 2022, 19:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `ecto` (Hex): affected `>=2.2.0, <2.2.1`; fixed in `2.2.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.013, the 70th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:25 UTC: First seen by agentprime
- 31 Oct 2026, 15:25 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2xxx-fhc8-9qvq)

## Sources

- [GitHub Advisory Database: GHSA-2xxx-fhc8-9qvq](https://github.com/advisories/GHSA-2xxx-fhc8-9qvq)
- [OSV: GHSA-2xxx-fhc8-9qvq](https://osv.dev/vulnerability/GHSA-2xxx-fhc8-9qvq)
- <https://nvd.nist.gov/vuln/detail/CVE-2017-20166>
- <https://github.com/elixir-ecto/ecto/pull/2125>
- <https://github.com/elixir-ecto/ecto/commit/db55b0cba6525c24ebddc88ef9ae0c1c00620250>
- <https://github.com/elixir-ecto/ecto>
- <https://groups.google.com/forum/#!topic/elixir-ecto/0m4NPfg_MMU>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2xxx-fhc8-9qvq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2xxx-fhc8-9qvq/>. Everything for agents: <https://agentprime.io/llms.txt>.
