# urllib3 streaming API improperly handles highly compressed data

Advisory record · `GHSA-2xpw-w6gg-jr37`

- **Identifiers:** `GHSA-2xpw-w6gg-jr37` · `CVE-2025-66471` · `PYSEC-2026-1994`
- **State:** Confirmed
- **Severity:** CVSS 8.9 High
- **Critical:** No
- **Weakness (CWE):** [CWE-409](https://cwe.mitre.org/data/definitions/409.html)
- **Tags:** [CWE-409](https://agentprime.io/advisories/tag/cwe-409.md)
- **Published:** 5 Dec 2025
- **Updated:** 25 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Dec 2025, 18:15 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `urllib3` (PyPI): affected `>=1.0, <2.6.0`; fixed in `2.6.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> urllib3 versions 1.0 through 2.5.0 are vulnerable when streaming compressed HTTP responses. A highly compressed response from an untrusted source can cause the client to fully decompress a small amount of data, consuming excessive CPU and memory even when the application requested only a small chunk. Upgrade to urllib3 2.6.0 or later, and also upgrade Brotli to 1.2.0 or brotlicffi to 1.2.0.0 if either is installed.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.9 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0073, the 54th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:09 UTC: First seen by agentprime
- 31 Oct 2026, 14:09 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2xpw-w6gg-jr37)

## Sources

- [GitHub Advisory Database: GHSA-2xpw-w6gg-jr37](https://github.com/advisories/GHSA-2xpw-w6gg-jr37)
- [OSV: GHSA-2xpw-w6gg-jr37](https://osv.dev/vulnerability/GHSA-2xpw-w6gg-jr37)
- <https://github.com/urllib3/urllib3/security/advisories/GHSA-2xpw-w6gg-jr37>
- <https://nvd.nist.gov/vuln/detail/CVE-2025-66471>
- <https://github.com/urllib3/urllib3/commit/c19571de34c47de3a766541b041637ba5f716ed7>
- <https://github.com/urllib3/urllib3/commit/d0fde3672e4a4093f7587858dccfc298eb66e46c>
- <https://github.com/advisories/GHSA-2xpw-w6gg-jr37>
- <https://github.com/pypa/advisory-database/tree/main/vulns/urllib3/PYSEC-2026-1994.yaml>
- <https://github.com/urllib3/urllib3>
- <https://pypi.org/project/urllib3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2xpw-w6gg-jr37>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2xpw-w6gg-jr37/>. Everything for agents: <https://agentprime.io/llms.txt>.
