# Next.js: Unauthenticated Remote Code Execution in Image Optimization API when AVIF files are used

Advisory record · `GHSA-2xp9-vwfh-vxw4`

- **Identifiers:** `GHSA-2xp9-vwfh-vxw4`
- **State:** Confirmed
- **Severity:** CVSS 4.0, no score published
- **Critical:** No
- **Weakness (CWE):** [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 8 Sept 2026
- **Updated:** 8 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 8 Sept 2026, 21:21 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `next` (npm): affected `>=10.0.0, <15.5.24 || >=16.0.0, <16.3.3`; fixed in `15.5.24`, `16.3.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- Score not published, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 8 Sept 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-2xp9-vwfh-vxw4](https://github.com/advisories/GHSA-2xp9-vwfh-vxw4)
- [OSV: GHSA-2xp9-vwfh-vxw4](https://osv.dev/vulnerability/GHSA-2xp9-vwfh-vxw4)
- <https://github.com/strukturag/libheif/security/advisories/GHSA-g89c-p67h-r497>
- <https://github.com/vercel/next.js/security/advisories/GHSA-2xp9-vwfh-vxw4>
- <https://github.com/vercel/next.js/pull/97875>
- <https://github.com/vercel/next.js/pull/97931>
- <https://github.com/vercel/next.js/commit/3a15b4ac6ac8e70b1a9b18ecc18e8434462899b3>
- <https://github.com/vercel/next.js/commit/409772ec807def20132d251ad48fd8d8ad4c73c2>
- <https://github.com/vercel/next.js/commit/7a5937a8ab20b89d0a961f75eabb11577f5d5998>
- <https://github.com/vercel/next.js>
- <https://github.com/vercel/next.js/releases/tag/v15.5.24>
- <https://github.com/vercel/next.js/releases/tag/v16.3.3>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2xp9-vwfh-vxw4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2xp9-vwfh-vxw4/>. Everything for agents: <https://agentprime.io/llms.txt>.
