# symfony/polyfill-intl-idn: xn-- labels with ASCII-only Punycode payloads are treated as equivalent to their decoded form

Advisory record · `GHSA-2xf4-cg6j-vhgq`

- **Identifiers:** `GHSA-2xf4-cg6j-vhgq` · `CVE-2026-46644` · `PKSA-df53-cqz9-c3zn` · `PKSA-dwsq-ppd2-mb1x`
- **State:** Confirmed
- **Severity:** CVSS 6.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-1289](https://cwe.mitre.org/data/definitions/1289.html)
- **Tags:** [CWE-1289](https://agentprime.io/advisories/tag/cwe-1289.md)
- **Published:** 28 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 28 May 2026, 19:52 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `symfony/polyfill` (Packagist): affected `>=1.17.1, <1.38.1`; fixed in `1.38.1`
- `symfony/polyfill-intl-idn` (Packagist): affected `>=1.17.1, <1.38.1`; fixed in `1.38.1`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.9 Medium, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0054, the 45th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:59 UTC: First seen by agentprime
- 31 Oct 2026, 13:59 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2xf4-cg6j-vhgq)

## Sources

- [GitHub Advisory Database: GHSA-2xf4-cg6j-vhgq](https://github.com/advisories/GHSA-2xf4-cg6j-vhgq)
- [OSV: GHSA-2xf4-cg6j-vhgq](https://osv.dev/vulnerability/GHSA-2xf4-cg6j-vhgq)
- <https://github.com/symfony/polyfill/security/advisories/GHSA-2xf4-cg6j-vhgq>
- <https://github.com/symfony/polyfill/commit/1be936e2491ccebe152bd736dfc91eb1422c8bec>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/polyfill-intl-idn/CVE-2026-46644.yaml>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/polyfill/CVE-2026-46644.yaml>
- <https://github.com/symfony/polyfill>
- <https://symfony.com/cve-2026-46644>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2xf4-cg6j-vhgq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2xf4-cg6j-vhgq/>. Everything for agents: <https://agentprime.io/llms.txt>.
