# Sinatra vulnerable to Reflected File Download attack

Advisory record · `GHSA-2x8x-jmrp-phxw`

- **Identifiers:** `GHSA-2x8x-jmrp-phxw` · `CVE-2022-45442`
- **State:** Confirmed
- **Severity:** CVSS 8.8 High
- **Critical:** No
- **Weakness (CWE):** [CWE-494](https://cwe.mitre.org/data/definitions/494.html)
- **Tags:** [CWE-494](https://agentprime.io/advisories/tag/cwe-494.md)
- **Published:** 30 Nov 2022
- **Updated:** 4 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 30 Nov 2022, 21:18 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `sinatra` (RubyGems): affected `>=3.0, <3.0.4 || >=2.0.0, <2.2.3`; fixed in `3.0.4`, `2.2.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.8 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0069, the 53rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 30 Nov 2022. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-2x8x-jmrp-phxw](https://github.com/advisories/GHSA-2x8x-jmrp-phxw)
- [OSV: GHSA-2x8x-jmrp-phxw](https://osv.dev/vulnerability/GHSA-2x8x-jmrp-phxw)
- <https://github.com/sinatra/sinatra/security/advisories/GHSA-2x8x-jmrp-phxw>
- <https://nvd.nist.gov/vuln/detail/CVE-2022-45442>
- <https://github.com/sinatra/sinatra/commit/ea8fc9495a350f7551b39e3025bfcd06f49f363b>
- <https://github.com/advisories/GHSA-8x94-hmjh-97hq>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sinatra/CVE-2022-45442.yml>
- <https://github.com/sinatra/sinatra>
- <https://lists.debian.org/debian-lts-announce/2023/01/msg00005.html>
- <https://lists.debian.org/debian-lts-announce/2024/09/msg00020.html>
- <https://www.blackhat.com/docs/eu-14/materials/eu-14-Hafif-Reflected-File-Download-A-New-Web-Attack-Vector.pdf>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2x8x-jmrp-phxw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2x8x-jmrp-phxw/>. Everything for agents: <https://agentprime.io/llms.txt>.
