# MLflow: SSRF on unauthenticated MLflow servers via third-party scorer kwargs in the scorer invoke, register, and GenAI evaluate endpoints

Advisory record · `GHSA-2wqp-q3c6-ccj5`

- **Identifiers:** `GHSA-2wqp-q3c6-ccj5` · `BIT-mlflow-2026-115886` · `CVE-2026-115886`
- **State:** Confirmed
- **Severity:** CVSS 6.5 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-470](https://cwe.mitre.org/data/definitions/470.html) · [CWE-918](https://cwe.mitre.org/data/definitions/918.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md) · [Server-side request forgery (SSRF)](https://agentprime.io/advisories/tag/ssrf.md)
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Oct 2026, 22:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `mlflow` (PyPI): affected `>=3.12.0rc0, <3.17.0`; fixed in `3.17.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> MLflow versions from 3.12.0rc0 before 3.17.0 are affected when the optional trulens and trulens-providers-litellm packages are installed on the tracking server. An unauthenticated attacker who can reach the server's scorer invoke endpoint can make it send an outbound HTTP request to an arbitrary host with attacker-chosen headers and body, which is a server-side request forgery. Upgrade mlflow to version 3.17.0 or later.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.5 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0068, the 52nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2wqp-q3c6-ccj5)

## Sources

- [GitHub Advisory Database: GHSA-2wqp-q3c6-ccj5](https://github.com/advisories/GHSA-2wqp-q3c6-ccj5)
- [OSV: GHSA-2wqp-q3c6-ccj5](https://osv.dev/vulnerability/GHSA-2wqp-q3c6-ccj5)
- <https://github.com/mlflow/mlflow/security/advisories/GHSA-2wqp-q3c6-ccj5>
- <https://github.com/mlflow/mlflow/pull/25890>
- <https://github.com/mlflow/mlflow/commit/bac30b4148c4f40045b4d4db07ae60ab3838803f>
- <https://github.com/mlflow/mlflow>
- <https://github.com/mlflow/mlflow/releases/tag/v3.17.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2wqp-q3c6-ccj5>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2wqp-q3c6-ccj5/>. Everything for agents: <https://agentprime.io/llms.txt>.
