# Server panic via missing authority or Host headers in google.golang.org/grpc

Advisory record · `GHSA-2v4p-qf9q-27wj`

- **Identifiers:** `GHSA-2v4p-qf9q-27wj` · `CVE-2026-84445` · `GO-2026-6443`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html) · [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md) · [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 15 Sept 2026
- **Updated:** 7 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 15 Sept 2026, 18:39 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `google.golang.org/grpc` (Go): affected `<1.82.2 || >=1.83.0, <1.83.2 || >=1.84.0-dev, <1.84.0-dev.0.20260825144003-d5a41119e0e3 || >=1.85.0-dev, <1.85.0-dev.0.20260825072537-93e31b48545e`; fixed in `1.82.2`, `1.83.2`, `1.84.0-dev.0.20260825144003-d5a41119e0e3`, `1.85.0-dev.0.20260825072537-93e31b48545e`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The google.golang.org/grpc package is affected in versions before 1.82.2, from 1.83.0 before 1.83.2, and in certain 1.84 and 1.85 development builds. A remote client can send a request without either the :authority or Host header to a server that uses xDS routing, which causes an unhandled panic that terminates the server. Upgrade to 1.82.2, 1.83.2, or the fixed development builds listed for the affected branch.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0064, the 50th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:12 UTC: First seen by agentprime
- 31 Oct 2026, 14:12 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GO-2026-6443)

## Sources

- [GitHub Advisory Database: GHSA-2v4p-qf9q-27wj](https://github.com/advisories/GHSA-2v4p-qf9q-27wj)
- [OSV: GHSA-2v4p-qf9q-27wj](https://osv.dev/vulnerability/GHSA-2v4p-qf9q-27wj)
- <https://github.com/grpc/grpc-go/security/advisories/GHSA-2v4p-qf9q-27wj>
- <https://github.com/grpc/grpc-go/pull/9365>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2v4p-qf9q-27wj>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2v4p-qf9q-27wj/>. Everything for agents: <https://agentprime.io/llms.txt>.
