# Symfony: Unbounded Recursion in the YAML Inline Lexer Lets a Single Document Crash the Process

Advisory record · `GHSA-2v3c-qxhr-7vpv`

- **Identifiers:** `GHSA-2v3c-qxhr-7vpv` · `CVE-2026-109413` · `PKSA-fyjn-dgwp-4tt3` · `PKSA-xz3r-9gp4-4m1z`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-674](https://cwe.mitre.org/data/definitions/674.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md)
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2026, 19:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `symfony/symfony` (Packagist): affected `>=2.0.0, <5.4.54 || >=6.0.0, <6.4.45 || >=7.0.0, <7.4.18 || >=8.0.0, <8.1.6`; fixed in `5.4.54`, `6.4.45`, `7.4.18`, `8.1.6`
- `symfony/yaml` (Packagist): affected `>=2.0.0, <5.4.54 || >=6.0.0, <6.4.45 || >=7.0.0, <7.4.18 || >=8.0.0, <8.1.6`; fixed in `5.4.54`, `6.4.45`, `7.4.18`, `8.1.6`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Symfony's symfony/symfony and symfony/yaml packages are affected in versions before 5.4.54, from 6.0.0 before 6.4.45, from 7.0.0 before 7.4.18, and from 8.0.0 before 8.1.6. An attacker can supply a YAML document with deeply nested inline collections, which exhausts the stack in the inline lexer and crashes the process or ends the request with a fatal error. Any code parsing untrusted YAML is affected, and no authentication is needed. Upgrade symfony/symfony and symfony/yaml to 5.4.54, 6.4.45, 7.4.18, or 8.1.6 according to your branch.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (Checkmarx)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0040, the 33rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:53 UTC: First seen by agentprime
- 31 Oct 2026, 13:53 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2v3c-qxhr-7vpv)

## Sources

- [GitHub Advisory Database: GHSA-2v3c-qxhr-7vpv](https://github.com/advisories/GHSA-2v3c-qxhr-7vpv)
- [OSV: GHSA-2v3c-qxhr-7vpv](https://osv.dev/vulnerability/GHSA-2v3c-qxhr-7vpv)
- <https://github.com/symfony/symfony/security/advisories/GHSA-2v3c-qxhr-7vpv>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-109413>
- <https://github.com/symfony/symfony/pull/65688>
- <https://github.com/symfony/symfony/commit/116287c3b5bc057e7a0420d2e52d384e14ea9417>
- <https://github.com/symfony/symfony/commit/2a8bf9c58d862b0c76a35ce288d1ba6a27223aad>
- <https://github.com/symfony/symfony/commit/8fb436fed9658a79d220e9f2b1ba8a2095559018>
- <https://github.com/symfony/symfony/commit/ab61e6cfd35042f16840a00f485eab2481dd4c2a>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2026-109413.yaml>
- <https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/yaml/CVE-2026-109413.yaml>
- <https://github.com/symfony/symfony>
- <https://github.com/symfony/symfony/releases/tag/v5.4.54>
- <https://github.com/symfony/symfony/releases/tag/v6.4.45>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2v3c-qxhr-7vpv>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2v3c-qxhr-7vpv/>. Everything for agents: <https://agentprime.io/llms.txt>.
