# LlamaIndex vulnerable to Path Traversal attack through its encode_image function

Advisory record · `GHSA-2rhq-96q8-4vjq`

- **Identifiers:** `GHSA-2rhq-96q8-4vjq` · `CVE-2025-6209` · `PYSEC-2025-65` · `PYSEC-2026-1558`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-29](https://cwe.mitre.org/data/definitions/29.html)
- **Tags:** [CWE-29](https://agentprime.io/advisories/tag/cwe-29.md)
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 7 Jul 2025, 15:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `llama-index-core` (PyPI): affected `>=0.11.23, <0.12.41`; fixed in `0.12.41`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (@huntr_ai)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0062, the 49th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 7 Jul 2025. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-2rhq-96q8-4vjq](https://github.com/advisories/GHSA-2rhq-96q8-4vjq)
- [OSV: GHSA-2rhq-96q8-4vjq](https://osv.dev/vulnerability/GHSA-2rhq-96q8-4vjq)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-6209>
- <https://github.com/run-llama/llama_index/commit/cdeaab91a204d1c3527f177dac37390327aef274>
- <https://github.com/pypa/advisory-database/tree/main/vulns/llama-index/PYSEC-2025-65.yaml>
- <https://github.com/run-llama/llama_index>
- <https://huntr.com/bounties/e89d14f8-bfe8-4c9a-bb2a-656c01cc9a68>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2rhq-96q8-4vjq>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2rhq-96q8-4vjq/>. Everything for agents: <https://agentprime.io/llms.txt>.
