# Improper Locking in JetBrains Kotlin

Advisory record · `GHSA-2qp4-g3q3-f92w`

- **Identifiers:** `GHSA-2qp4-g3q3-f92w` · `CVE-2022-24329`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-667](https://cwe.mitre.org/data/definitions/667.html) · [CWE-829](https://cwe.mitre.org/data/definitions/829.html)
- **Tags:** [CWE-667](https://agentprime.io/advisories/tag/cwe-667.md) · [CWE-829](https://agentprime.io/advisories/tag/cwe-829.md)
- **Published:** 26 Feb 2022
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 Feb 2022, 00:00 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.jetbrains.kotlin:kotlin-stdlib` (Maven): affected `<1.6.0`; fixed in `1.6.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The kotlin-stdlib package on Maven is affected in versions before 1.6.0. The source gives few details: it states that dependencies could not be locked for Multiplatform Gradle projects, and does not describe an attacker's access requirements or what an attacker could do. Upgrade kotlin-stdlib to 1.6.0 or later.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.022, the 82nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:18 UTC: First seen by agentprime
- 31 Oct 2026, 14:18 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2qp4-g3q3-f92w)

## Sources

- [GitHub Advisory Database: GHSA-2qp4-g3q3-f92w](https://github.com/advisories/GHSA-2qp4-g3q3-f92w)
- [OSV: GHSA-2qp4-g3q3-f92w](https://osv.dev/vulnerability/GHSA-2qp4-g3q3-f92w)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-24329>
- <https://blog.jetbrains.com/>
- <https://blog.jetbrains.com/blog/2022/02/08/jetbrains-security-bulletin-q4-2021>
- <https://github.com/JetBrains/kotlin>
- <https://www.oracle.com/security-alerts/cpuapr2022.html>
- <https://www.oracle.com/security-alerts/cpujul2022.html>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2qp4-g3q3-f92w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2qp4-g3q3-f92w/>. Everything for agents: <https://agentprime.io/llms.txt>.
