# Cross-Site Scripting in jquery

Advisory record · `GHSA-2pqj-h3vj-pqgw`

- **Identifiers:** `GHSA-2pqj-h3vj-pqgw` · `CVE-2012-6708`
- **State:** Confirmed
- **Severity:** CVSS 6.1 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-64](https://cwe.mitre.org/data/definitions/64.html) · [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-64](https://agentprime.io/advisories/tag/cwe-64.md)
- **Published:** 1 Sept 2020
- **Updated:** 8 Mar 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Sept 2020, 16:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `jquery` (npm): affected `<1.9.0`; fixed in `1.9.0`
- `org.webjars.npm:jquery` (Maven): affected `<1.9.0`; fixed in `1.9.0`
- `jQuery` (NuGet): affected `<1.9.0`; fixed in `1.9.0`
- `jquery-rails` (RubyGems): affected `<2.2.0`; fixed in `2.2.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.1 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.086, the 95th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 1 Sept 2020. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-2pqj-h3vj-pqgw](https://github.com/advisories/GHSA-2pqj-h3vj-pqgw)
- [OSV: GHSA-2pqj-h3vj-pqgw](https://osv.dev/vulnerability/GHSA-2pqj-h3vj-pqgw)
- <https://nvd.nist.gov/vuln/detail/CVE-2017-16011>
- <https://nvd.nist.gov/vuln/detail/CVE-2012-6708>
- <https://github.com/jquery/jquery/commit/05531fc4080ae24070930d15ae0cea7ae056457d>
- <https://web.archive.org/web/20200227132049/http://www.securityfocus.com/bid/102792>
- <https://snyk.io/vuln/npm:jquery:20120206>
- <https://security.snyk.io/vuln/SNYK-DOTNET-JQUERY-450223>
- <https://research.insecurelabs.org/jquery/test>
- <https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E>
- <https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E>
- <https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E>
- <https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jquery-rails/CVE-2012-6708.yml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2pqj-h3vj-pqgw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2pqj-h3vj-pqgw/>. Everything for agents: <https://agentprime.io/llms.txt>.
