# Denial of service in Open Policy Agent

Advisory record · `GHSA-2m4x-4q9j-w97g`

- **Identifiers:** `GHSA-2m4x-4q9j-w97g` · `CVE-2022-33082` · `GO-2022-0574`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-703](https://cwe.mitre.org/data/definitions/703.html)
- **Tags:** [CWE-703](https://agentprime.io/advisories/tag/cwe-703.md)
- **Published:** 1 Jul 2022
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 1 Jul 2022, 00:01 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/open-policy-agent/opa` (Go): affected `<0.42.0`; fixed in `0.42.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.017, the 77th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:43 UTC: First seen by agentprime
- 31 Oct 2026, 14:43 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2m4x-4q9j-w97g)

## Sources

- [GitHub Advisory Database: GHSA-2m4x-4q9j-w97g](https://github.com/advisories/GHSA-2m4x-4q9j-w97g)
- [OSV: GHSA-2m4x-4q9j-w97g](https://osv.dev/vulnerability/GHSA-2m4x-4q9j-w97g)
- <https://nvd.nist.gov/vuln/detail/CVE-2022-33082>
- <https://github.com/open-policy-agent/opa/issues/4761>
- <https://github.com/open-policy-agent/opa/issues/4762>
- <https://github.com/open-policy-agent/opa/pull/4701>
- <https://github.com/open-policy-agent/opa/commit/064f6168a8dfebdeb2ea147f7882bb9f5d2b7f67>
- <https://github.com/open-policy-agent/opa>
- <https://github.com/open-policy-agent/opa/blob/598176de326025451025225aca53e85708d5f1db/ast/compile.go#L1224>
- <https://pkg.go.dev/vuln/GO-2022-0574>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2m4x-4q9j-w97g>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2m4x-4q9j-w97g/>. Everything for agents: <https://agentprime.io/llms.txt>.
