# Apache CXF: Untrusted JMS configuration can lead to RCE

Advisory record · `GHSA-2hvc-5c6v-f533`

- **Identifiers:** `GHSA-2hvc-5c6v-f533` · `CVE-2026-44417`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-15](https://cwe.mitre.org/data/definitions/15.html) · [CWE-20](https://cwe.mitre.org/data/definitions/20.html)
- **Tags:** [CWE-15](https://agentprime.io/advisories/tag/cwe-15.md) · [CWE-20](https://agentprime.io/advisories/tag/cwe-20.md)
- **Published:** 26 May 2026
- **Updated:** 29 Jun 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 26 May 2026, 13:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.apache.cxf:cxf-rt-transports-jms` (Maven): affected `>=4.2.0, <4.2.1 || >=4.1.0, <4.1.6 || <3.6.11`; fixed in `4.2.1`, `4.1.6`, `3.6.11`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Apache CXF's cxf-rt-transports-jms package is affected in versions 4.2.0 before 4.2.1, 4.1.0 before 4.1.6, and before 3.6.11. The source describes an incomplete fix for CVE-2025-48913, leaving another code path that may allow code execution if untrusted users can configure JMS. Upgrade to 4.2.1, 4.1.6, or 3.6.11.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.0066, the 51st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:20 UTC: First seen by agentprime
- 31 Oct 2026, 14:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2hvc-5c6v-f533)

## Sources

- [GitHub Advisory Database: GHSA-2hvc-5c6v-f533](https://github.com/advisories/GHSA-2hvc-5c6v-f533)
- [OSV: GHSA-2hvc-5c6v-f533](https://osv.dev/vulnerability/GHSA-2hvc-5c6v-f533)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-44417>
- <https://github.com/apache/cxf>
- <https://lists.apache.org/thread/bqg6gjy2cx7rfyqjxcpv3jwjvmclvz4o>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2hvc-5c6v-f533>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2hvc-5c6v-f533/>. Everything for agents: <https://agentprime.io/llms.txt>.
