# Eclipse Jetty Digest Authentication: ISO-8859-1 lossy encoding allows authentication bypass via character substitution

Advisory record · `GHSA-2fvj-hgj9-j2gr`

- **Identifiers:** `GHSA-2fvj-hgj9-j2gr` · `CVE-2026-10050`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-173](https://cwe.mitre.org/data/definitions/173.html) · [CWE-303](https://cwe.mitre.org/data/definitions/303.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-173](https://agentprime.io/advisories/tag/cwe-173.md)
- **Published:** 22 Jul 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Jul 2026, 22:55 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `org.eclipse.jetty:jetty-security` (Maven): affected `>=9.4.0.v20161208, <9.4.63 || >=10.0.0, <10.0.31 || >=11.0.0, <11.0.31 || >=12.0.0, <12.0.36 || >=12.1.0, <12.1.10`; fixed in `9.4.63`, `10.0.31`, `11.0.31`, `12.0.36`, `12.1.10`
- `org.eclipse.jetty.ee8:jetty-ee8-security` (Maven): affected `>=12.0.0, <12.0.36 || >=12.1.0, <12.1.10`; fixed in `12.0.36`, `12.1.10`
- `org.eclipse.jetty.ee9:jetty-ee9-security` (Maven): affected `>=12.0.0, <12.0.36 || >=12.1.0, <12.1.10`; fixed in `12.0.36`, `12.1.10`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`, from CNA (eclipse)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0063, the 50th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:16 UTC: First seen by agentprime
- 31 Oct 2026, 14:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2fvj-hgj9-j2gr)

## Sources

- [GitHub Advisory Database: GHSA-2fvj-hgj9-j2gr](https://github.com/advisories/GHSA-2fvj-hgj9-j2gr)
- [OSV: GHSA-2fvj-hgj9-j2gr](https://osv.dev/vulnerability/GHSA-2fvj-hgj9-j2gr)
- <https://github.com/jetty/jetty.project/security/advisories/GHSA-2fvj-hgj9-j2gr>
- <https://github.com/jetty/jetty.project/issues/15136>
- <https://github.com/jetty/jetty.project/pull/15160>
- <https://github.com/jetty/jetty.project/pull/15183>
- <https://github.com/jetty/jetty.project/commit/4bcdbc7db387ce9e20e2c7571a7250280466221d>
- <https://github.com/jetty/jetty.project/commit/d0bb829ccecbf19e3ad3d32f2649b2800f01222d>
- <https://github.com/jetty/jetty.project>
- <https://github.com/jetty/jetty.project/releases/tag/jetty-12.0.36>
- <https://github.com/jetty/jetty.project/releases/tag/jetty-12.1.10>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2fvj-hgj9-j2gr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2fvj-hgj9-j2gr/>. Everything for agents: <https://agentprime.io/llms.txt>.
