# Django Denial-of-service possibility in truncatechars_html and truncatewords_html template filters

Advisory record · `GHSA-2f9x-5v75-3qv4`

- **Identifiers:** `GHSA-2f9x-5v75-3qv4` · `CVE-2018-7537` · `PYSEC-2018-6`
- **State:** Confirmed
- **Severity:** CVSS 5.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-185](https://cwe.mitre.org/data/definitions/185.html)
- **Tags:** [CWE-185](https://agentprime.io/advisories/tag/cwe-185.md)
- **Published:** 4 Jan 2019
- **Updated:** 27 Nov 2024
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 Jan 2019, 17:50 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `django` (PyPI): affected `>=2.0, <2.0.3 || >=1.11, <1.11.11 || >=1.8, <1.8.19`; fixed in `2.0.3`, `1.11.11`, `1.8.19`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.3 Medium, CVSS 3.0: `CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** 0.044, the 91st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 4 Jan 2019. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-2f9x-5v75-3qv4](https://github.com/advisories/GHSA-2f9x-5v75-3qv4)
- [OSV: GHSA-2f9x-5v75-3qv4](https://osv.dev/vulnerability/GHSA-2f9x-5v75-3qv4)
- <https://nvd.nist.gov/vuln/detail/CVE-2018-7537>
- <https://github.com/django/django/commit/94c5da1d17a6b0d378866c66b605102c19f7988c>
- <https://github.com/django/django/commit/a91436360b79a6ff995c3e5018bcc666dfaf1539>
- <https://github.com/django/django/commit/d17974a287a6ea2e361daff88fcc004cbd6835fa>
- <https://access.redhat.com/errata/RHSA-2018:2927>
- <https://access.redhat.com/errata/RHSA-2019:0265>
- <https://github.com/advisories/GHSA-2f9x-5v75-3qv4>
- <https://github.com/django/django>
- <https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2018-6.yaml>
- <https://lists.debian.org/debian-lts-announce/2018/03/msg00006.html>
- <https://usn.ubuntu.com/3591-1>
- <https://www.debian.org/security/2018/dsa-4161>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2f9x-5v75-3qv4>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2f9x-5v75-3qv4/>. Everything for agents: <https://agentprime.io/llms.txt>.
