# Magento LTS has Weak API Session ID — Predictable MD5 of Time-Derived Inputs

Advisory record · `GHSA-2cwr-gcf9-pvxr`

- **Identifiers:** `GHSA-2cwr-gcf9-pvxr` · `CVE-2026-42155` · `PKSA-qjnm-jjkr-qktb`
- **State:** Confirmed
- **Severity:** CVSS 9.3 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-330](https://cwe.mitre.org/data/definitions/330.html) · [CWE-331](https://cwe.mitre.org/data/definitions/331.html) · [CWE-338](https://cwe.mitre.org/data/definitions/338.html)
- **Tags:** [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md) · [CWE-331](https://agentprime.io/advisories/tag/cwe-331.md)
- **Published:** 5 May 2026
- **Updated:** 16 May 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 May 2026, 19:35 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.3: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `openmage/magento-lts` (Packagist): affected `<20.18.0`; fixed in `20.18.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.3 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0037, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 5 May 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-2cwr-gcf9-pvxr](https://github.com/advisories/GHSA-2cwr-gcf9-pvxr)
- [OSV: GHSA-2cwr-gcf9-pvxr](https://osv.dev/vulnerability/GHSA-2cwr-gcf9-pvxr)
- <https://github.com/OpenMage/magento-lts/security/advisories/GHSA-2cwr-gcf9-pvxr>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-42155>
- <https://github.com/OpenMage/magento-lts>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2cwr-gcf9-pvxr>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2cwr-gcf9-pvxr/>. Everything for agents: <https://agentprime.io/llms.txt>.
