# Pleroma Path Traversal vulnerability

Advisory record · `GHSA-2c28-m2m7-mf55`

- **Identifiers:** `GHSA-2c28-m2m7-mf55` · `CVE-2023-5588`
- **State:** Confirmed
- **Severity:** CVSS 2.6 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md)
- **Published:** 16 Oct 2023
- **Updated:** 10 Dec 2025
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 16 Oct 2023, 00:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `pleroma` (Hex): affected `<2.5.3`; fixed in `2.5.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.6 Low, CVSS 3.1: `CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`, from CNA (VulDB)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0071, the 53rd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:26 UTC: First seen by agentprime
- 31 Oct 2026, 15:26 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2c28-m2m7-mf55)

## Sources

- [GitHub Advisory Database: GHSA-2c28-m2m7-mf55](https://github.com/advisories/GHSA-2c28-m2m7-mf55)
- [OSV: GHSA-2c28-m2m7-mf55](https://osv.dev/vulnerability/GHSA-2c28-m2m7-mf55)
- <https://nvd.nist.gov/vuln/detail/CVE-2023-5588>
- <https://github.com/kphrx/pleroma/pull/197>
- <https://github.com/kphrx/pleroma/commit/2c795094535537a8607cc0d3b7f076a609636f40>
- <https://github.com/kphrx/pleroma>
- <https://github.com/kphrx/pleroma/commits/v2.5.3>
- <https://vuldb.com/?ctiid.242187>
- <https://vuldb.com/?id.242187>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2c28-m2m7-mf55>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2c28-m2m7-mf55/>. Everything for agents: <https://agentprime.io/llms.txt>.
