# Bad documentation of error handling in ParseWithClaims can lead to potentially dangerous situations

Advisory record · `GHSA-29wx-vh33-7x7r`

- **Identifiers:** `GHSA-29wx-vh33-7x7r` · `CVE-2024-51744` · `GO-2024-3250`
- **State:** Confirmed
- **Severity:** CVSS 3.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-347](https://cwe.mitre.org/data/definitions/347.html) · [CWE-755](https://cwe.mitre.org/data/definitions/755.html)
- **Tags:** [Weak cryptography or TLS](https://agentprime.io/advisories/tag/weak-crypto.md) · [CWE-755](https://agentprime.io/advisories/tag/cwe-755.md)
- **Published:** 4 Nov 2024
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 4 Nov 2024, 23:22 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/golang-jwt/jwt/v4` (Go): affected `<4.5.1`; fixed in `4.5.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Versions of github.com/golang-jwt/jwt/v4 before 4.5.1 can return combined errors from ParseWithClaims where a token is both expired and has an invalid signature. An application that checks only for the expired-token error with errors.Is may therefore accept a token whose signature is invalid. Upgrade to 4.5.1, which returns immediately on dangerous failures such as an invalid signature. If you cannot upgrade, check for all returned errors, handling signature failures before expiry.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.1 Low, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0059, the 48th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:15 UTC: First seen by agentprime
- 31 Oct 2026, 14:15 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-29wx-vh33-7x7r)

## Sources

- [GitHub Advisory Database: GHSA-29wx-vh33-7x7r](https://github.com/advisories/GHSA-29wx-vh33-7x7r)
- [OSV: GHSA-29wx-vh33-7x7r](https://osv.dev/vulnerability/GHSA-29wx-vh33-7x7r)
- <https://github.com/golang-jwt/jwt/security/advisories/GHSA-29wx-vh33-7x7r>
- <https://nvd.nist.gov/vuln/detail/CVE-2024-51744>
- <https://github.com/golang-jwt/jwt/commit/7b1c1c00a171c6c79bbdb40e4ce7d197060c1c2c>
- <https://github.com/golang-jwt/jwt>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-29wx-vh33-7x7r>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-29wx-vh33-7x7r/>. Everything for agents: <https://agentprime.io/llms.txt>.
