# body-parser vulnerable to Denial of Service via trailing bytes after a compressed request body

Advisory record · `GHSA-27r3-jxmh-p828`

- **Identifiers:** `GHSA-27r3-jxmh-p828` · `CVE-2026-111181`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-248](https://cwe.mitre.org/data/definitions/248.html)
- **Tags:** [CWE-248](https://agentprime.io/advisories/tag/cwe-248.md)
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 23 Oct 2026, 20:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `body-parser` (npm): affected `>=2.0.0, <2.4.0 || <1.20.9`; fixed in `2.4.0`, `1.20.9`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> The npm package body-parser, in versions before 1.20.9 and from 2.0.0 before 2.4.0, can crash a process when a request has a Content-Encoding such as gzip and its body is one valid compressed frame followed by trailing bytes. No authentication or matching route is needed, since parsing happens before routing, so a single request can terminate an application using default options. Upgrade to body-parser 1.20.9 or 2.4.0. As a workaround, set inflate to false if compressed request bodies are not needed.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (openjs)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0039, the 33rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:33 UTC: First seen by agentprime
- 31 Oct 2026, 13:33 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-27r3-jxmh-p828)

## Sources

- [GitHub Advisory Database: GHSA-27r3-jxmh-p828](https://github.com/advisories/GHSA-27r3-jxmh-p828)
- [OSV: GHSA-27r3-jxmh-p828](https://osv.dev/vulnerability/GHSA-27r3-jxmh-p828)
- <https://github.com/expressjs/body-parser/security/advisories/GHSA-27r3-jxmh-p828>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-111181>
- <https://github.com/expressjs/body-parser/commit/1260c3845f54502a05a87594f09a334786bb34d7>
- <https://github.com/expressjs/body-parser/commit/f7075eae3a84c3473ab4bf0a777da28db208e916>
- <https://cna.openjsf.org/security-advisories.html>
- <https://github.com/expressjs/body-parser>
- <https://github.com/expressjs/body-parser/releases/tag/1.20.9>
- <https://github.com/expressjs/body-parser/releases/tag/v2.4.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-27r3-jxmh-p828>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-27r3-jxmh-p828/>. Everything for agents: <https://agentprime.io/llms.txt>.
