# Packetbeat does not properly validate an array index in multiple protocol parser components

Advisory record · `GHSA-27qj-9gvp-8rh9`

- **Identifiers:** `GHSA-27qj-9gvp-8rh9` · `CVE-2026-26933` · `GO-2026-4789`
- **State:** Confirmed
- **Severity:** CVSS 5.7 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html)
- **Tags:** [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 19 Mar 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 19 Mar 2026, 18:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/elastic/beats/v7` (Go): affected `<7.0.0-alpha2.0.20260126223743-dec1b31111ec`; fixed in `7.0.0-alpha2.0.20260126223743-dec1b31111ec`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Packetbeat in github.com/elastic/beats/v7 versions before 7.0.0-alpha2.0.20260126223743-dec1b31111ec is affected by improper array index validation in several protocol parsers. An attacker who can send crafted, malformed packets to a monitored network interface, either from the same network segment or by controlling traffic routed to it, can trigger out-of-bounds reads that crash the application or exhaust resources. Upgrade to 7.0.0-alpha2.0.20260126223743-dec1b31111ec or later.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 5.7 Medium, CVSS 3.1: `CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`, from CNA (elastic)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0024, the 14th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-27qj-9gvp-8rh9)

## Sources

- [GitHub Advisory Database: GHSA-27qj-9gvp-8rh9](https://github.com/advisories/GHSA-27qj-9gvp-8rh9)
- [OSV: GHSA-27qj-9gvp-8rh9](https://osv.dev/vulnerability/GHSA-27qj-9gvp-8rh9)
- <https://nvd.nist.gov/vuln/detail/CVE-2026-26933>
- <https://github.com/elastic/beats/commit/941098459db6556b837194f40c076b08d51137cb>
- <https://github.com/elastic/beats/commit/dec1b31111ec3500b82db21ba67dde5c914ee94d>
- <https://discuss.elastic.co/t/packetbeat-8-19-11-9-2-5-security-update-esa-2026-11/385533>
- <https://github.com/elastic/beats>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-27qj-9gvp-8rh9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-27qj-9gvp-8rh9/>. Everything for agents: <https://agentprime.io/llms.txt>.
