# RabbitMQ amqp091-go: Plaintext Credential Exposure via Exported PLAIN Authentication Struct Fields

Advisory record · `GHSA-27gv-rfvv-22mv`

- **Identifiers:** `GHSA-27gv-rfvv-22mv` · `CVE-2026-77407` · `GO-2026-6491`
- **State:** Confirmed
- **Severity:** CVSS 7.0 High
- **Critical:** No
- **Weakness (CWE):** [CWE-316](https://cwe.mitre.org/data/definitions/316.html)
- **Tags:** [CWE-316](https://agentprime.io/advisories/tag/cwe-316.md)
- **Published:** 17 Sept 2026
- **Updated:** 1 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 17 Sept 2026, 17:04 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/rabbitmq/amqp091-go` (Go): affected `<1.13.0`; fixed in `1.13.0`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> GHSA-27gv-rfvv-22mv affects the Go module github.com/rabbitmq/amqp091-go before 1.13.0. The PLAIN authentication struct keeps the username and password as exported plaintext fields, so code that reflects over the connection object, such as logging, APM, or panic-dump tools, can read and log the password. Upgrade to version 1.13.0 or later. The source gives few details on exploitation conditions.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.0 High, CVSS 4.0: `CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:L/SA:L`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0013, the 2nd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:12 UTC: First seen by agentprime
- 31 Oct 2026, 14:12 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-27gv-rfvv-22mv)

## Sources

- [GitHub Advisory Database: GHSA-27gv-rfvv-22mv](https://github.com/advisories/GHSA-27gv-rfvv-22mv)
- [OSV: GHSA-27gv-rfvv-22mv](https://osv.dev/vulnerability/GHSA-27gv-rfvv-22mv)
- <https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-27gv-rfvv-22mv>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-77407>
- <https://github.com/rabbitmq/amqp091-go/pull/350>
- <https://github.com/rabbitmq/amqp091-go/commit/fa013b8447eb60988db3c9281ff6b981e4d2fb4f>
- <https://github.com/rabbitmq/amqp091-go>
- <https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-27gv-rfvv-22mv>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-27gv-rfvv-22mv/>. Everything for agents: <https://agentprime.io/llms.txt>.
