# Shopware exposes sensitive user information via CSV export mapping

Advisory record · `GHSA-27c9-vp3w-6ww8`

- **Identifiers:** `GHSA-27c9-vp3w-6ww8` · `PKSA-cb17-wqsx-y85w` · `PKSA-kypv-cx5n-qkc8`
- **State:** Confirmed
- **Severity:** CVSS 4.9 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-212](https://cwe.mitre.org/data/definitions/212.html)
- **Tags:** [CWE-212](https://agentprime.io/advisories/tag/cwe-212.md)
- **Published:** 21 Oct 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 21 Oct 2025, 18:03 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `shopware/platform` (Packagist): affected `>=6.7.0.0, <6.7.3.1 || <6.6.10.7`; fixed in `6.7.3.1`, `6.6.10.7`
- `shopware/core` (Packagist): affected `>=6.7.0.0, <6.7.3.1 || <6.6.10.7`; fixed in `6.7.3.1`, `6.6.10.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Shopware platform and core, versions before 6.6.10.7 and from 6.7.0.0 before 6.7.3.1, expose sensitive user data through CSV export mapping. An attacker needs an account that can create import/export profiles and run exports, after which they can include password hashes and password reset tokens in an export and obtain them. Upgrade to shopware/platform or shopware/core 6.6.10.7 or 6.7.3.1.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.9 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 14:03 UTC: First seen by agentprime
- 31 Oct 2026, 14:03 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-27c9-vp3w-6ww8)

## Sources

- [GitHub Advisory Database: GHSA-27c9-vp3w-6ww8](https://github.com/advisories/GHSA-27c9-vp3w-6ww8)
- [OSV: GHSA-27c9-vp3w-6ww8](https://osv.dev/vulnerability/GHSA-27c9-vp3w-6ww8)
- <https://github.com/shopware/shopware/security/advisories/GHSA-27c9-vp3w-6ww8>
- <https://github.com/shopware/shopware/commit/c2c98050aff7b90fe7232f6dac9b6b7143183083>
- <https://github.com/shopware/shopware>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-27c9-vp3w-6ww8>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-27c9-vp3w-6ww8/>. Everything for agents: <https://agentprime.io/llms.txt>.
