# Jetty vulnerable to incorrect handling of invalid large TLS frame, exhausting CPU resources

Advisory record · `GHSA-26vr-8j45-3r4w`

- **Identifiers:** `GHSA-26vr-8j45-3r4w` · `BIT-jenkins-2021-28165` · `CVE-2021-28165`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** Yes: CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-400](https://cwe.mitre.org/data/definitions/400.html) · [CWE-551](https://cwe.mitre.org/data/definitions/551.html) · [CWE-755](https://cwe.mitre.org/data/definitions/755.html)
- **Tags:** [Denial of service](https://agentprime.io/advisories/tag/dos.md) · [CWE-551](https://agentprime.io/advisories/tag/cwe-551.md) · [CWE-755](https://agentprime.io/advisories/tag/cwe-755.md)
- **Published:** 6 Apr 2021
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Apr 2021, 17:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 7.5 (7.0 or more) and EPSS 0.54 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `org.eclipse.jetty:jetty-server` (Maven): affected `>=7.2.2, <9.4.39 || >=10.0.0, <10.0.2 || >=11.0.0, <11.0.2`; fixed in `9.4.39`, `10.0.2`, `11.0.2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Jetty's jetty-server package, versions from 7.2.2 before 9.4.39, from 10.0.0 before 10.0.2, and from 11.0.0 before 11.0.2, mishandles an invalid TLS frame larger than 17408 bytes when SSL/TLS is used with HTTP/1.1, HTTP/2, or WebSocket. A remote attacker who can send such frames to the server can drive CPU usage to 100%. Upgrade to 9.4.39, 10.0.2, or 11.0.2. The source describes a workaround that involves compiling and deploying a custom class and editing Jetty configuration files, but it gives few details beyond that.

Written 2 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (eclipse)

- **CISA KEV:** Not listed.
- **EPSS:** 0.54, the 99th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:20 UTC: First seen by agentprime
- 31 Oct 2026, 14:20 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-26vr-8j45-3r4w)

## Sources

- [GitHub Advisory Database: GHSA-26vr-8j45-3r4w](https://github.com/advisories/GHSA-26vr-8j45-3r4w)
- [OSV: GHSA-26vr-8j45-3r4w](https://osv.dev/vulnerability/GHSA-26vr-8j45-3r4w)
- <https://github.com/eclipse/jetty.project/security/advisories/GHSA-26vr-8j45-3r4w>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-28165>
- <https://www.oracle.com/security-alerts/cpuoct2021.html>
- <https://lists.apache.org/thread.html/rc907ed7b089828364437de5ed57fa062330970dc1bc5cd214b711f77@%3Ccommits.zookeeper.apache.org%3E>
- <https://lists.apache.org/thread.html/rc6c43c3180c0efe00497c73dd374cd34b62036cb67987ad42c1f2dce@%3Creviews.spark.apache.org%3E>
- <https://lists.apache.org/thread.html/rc4dbc9907b0bdd634200ac90a15283d9c143c11af66e7ec72128d020@%3Cjira.kafka.apache.org%3E>
- <https://lists.apache.org/thread.html/rc4779abc1cface47e956cf9f8910f15d79c24477e7b1ac9be076a825@%3Cjira.kafka.apache.org%3E>
- <https://lists.apache.org/thread.html/rbd9a837a18ca57ac0d9b4165a6eec95ee132f55d025666fe41099f33@%3Creviews.spark.apache.org%3E>
- <https://lists.apache.org/thread.html/rbcd7b477df55857bb6cae21fcc4404683ac98aac1a47551f0dc55486@%3Cissues.zookeeper.apache.org%3E>
- <https://lists.apache.org/thread.html/rbc075a4ac85e7a8e47420b7383f16ffa0af3b792b8423584735f369f@%3Cissues.solr.apache.org%3E>
- <https://lists.apache.org/thread.html/rbba0b02a3287e34af328070dd58f7828612f96e2e64992137f4dc63d@%3Cnotifications.zookeeper.apache.org%3E>
- <https://lists.apache.org/thread.html/rbab9e67ec97591d063905bc7d4743e6a673f1bc457975fc0445ac97f@%3Cissues.hbase.apache.org%3E>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-26vr-8j45-3r4w>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-26vr-8j45-3r4w/>. Everything for agents: <https://agentprime.io/llms.txt>.
