# MLflow vulnerable to remote code execution on unauthenticated servers via third-party scorer deserialization importing caller-placed artifact modules

Advisory record · `GHSA-26p8-2jq9-3vq9`

- **Identifiers:** `GHSA-26p8-2jq9-3vq9` · `CVE-2026-116692`
- **State:** Confirmed
- **Severity:** CVSS 9.8 Critical
- **Critical:** Yes: CVSS 9+
- **Weakness (CWE):** [CWE-94](https://cwe.mitre.org/data/definitions/94.html) · [CWE-470](https://cwe.mitre.org/data/definitions/470.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md)
- **Published:** 27 Oct 2026
- **Updated:** 27 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 27 Oct 2026, 21:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.8: 9.0 or more.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `mlflow` (PyPI): affected `>=3.12.0rc0, <3.17.0`; fixed in `3.17.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.8 Critical, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0070, the 53rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 27 Oct 2026, 20:03 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-116692)
- 27 Oct 2026, 21:18 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-116692)
- 31 Oct 2026, 14:07 UTC: First seen by agentprime
- 31 Oct 2026, 14:07 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-26p8-2jq9-3vq9)

## Sources

- [GitHub Advisory Database: GHSA-26p8-2jq9-3vq9](https://github.com/advisories/GHSA-26p8-2jq9-3vq9)
- [OSV: GHSA-26p8-2jq9-3vq9](https://osv.dev/vulnerability/GHSA-26p8-2jq9-3vq9)
- <https://github.com/mlflow/mlflow/security/advisories/GHSA-26p8-2jq9-3vq9>
- <https://github.com/mlflow/mlflow/pull/25906>
- <https://github.com/mlflow/mlflow/commit/a732443e695c3c677680c54320efc394c81654ab>
- <https://github.com/mlflow/mlflow>
- <https://github.com/mlflow/mlflow/releases/tag/v3.17.0>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-26p8-2jq9-3vq9>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-26p8-2jq9-3vq9/>. Everything for agents: <https://agentprime.io/llms.txt>.
