# Next.js has a Middleware / Proxy bypass in App Router applications via segment-prefetch routes - Incomplete Fix Follow-Up

Advisory record · `GHSA-26hh-7cqf-hhc6`

- **Identifiers:** `GHSA-26hh-7cqf-hhc6` · `CVE-2026-45109`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-288](https://cwe.mitre.org/data/definitions/288.html) · [CWE-358](https://cwe.mitre.org/data/definitions/358.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-358](https://agentprime.io/advisories/tag/cwe-358.md)
- **Published:** 11 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 11 May 2026, 16:21 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `next` (npm): affected `>=15.2.0, <15.5.18 || >=16.0.0, <16.2.6`; fixed in `15.5.18`, `16.2.6`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0085, the 58th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 11 May 2026, 16:21 UTC: [Confirmed by GitHub Advisory Database](https://github.com/advisories/GHSA-26hh-7cqf-hhc6)
- 13 May 2026, 17:11 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-45109)
- 13 May 2026, 18:16 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-45109)

## Sources

- [GitHub Advisory Database: GHSA-26hh-7cqf-hhc6](https://github.com/advisories/GHSA-26hh-7cqf-hhc6)
- [OSV: GHSA-26hh-7cqf-hhc6](https://osv.dev/vulnerability/GHSA-26hh-7cqf-hhc6)
- <https://github.com/vercel/next.js/security/advisories/GHSA-267c-6grr-h53f>
- <https://github.com/vercel/next.js/security/advisories/GHSA-26hh-7cqf-hhc6>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-45109>
- <https://github.com/vercel/next.js>
- <https://github.com/vercel/next.js/releases/tag/v15.5.18>
- <https://github.com/vercel/next.js/releases/tag/v16.2.6>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-26hh-7cqf-hhc6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-26hh-7cqf-hhc6/>. Everything for agents: <https://agentprime.io/llms.txt>.
