# frp: Unauthenticated Remote Denial of Service in the frp SSH Tunnel Gateway via Integer Overflow

Advisory record · `GHSA-26gq-p25f-99cp`

- **Identifiers:** `GHSA-26gq-p25f-99cp` · `CVE-2026-73564` · `GO-2026-6103`
- **State:** Confirmed
- **Severity:** CVSS 8.7 High
- **Critical:** No
- **Weakness (CWE):** [CWE-129](https://cwe.mitre.org/data/definitions/129.html) · [CWE-190](https://cwe.mitre.org/data/definitions/190.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md) · [CWE-129](https://agentprime.io/advisories/tag/cwe-129.md)
- **Published:** 24 Jul 2026
- **Updated:** 18 Aug 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 24 Jul 2026, 21:48 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/fatedier/frp` (Go): affected `>=0.53.0, <0.70.1`; fixed in `0.70.1`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> frp versions 0.53.0 through 0.70.0 are vulnerable to an integer overflow in the frps SSH Tunnel Gateway when it parses SSH exec requests, but only when the gateway is enabled. An unauthenticated remote attacker can crash the whole frps process with a single crafted request. Upgrade to frp 0.70.1, or disable the SSH Tunnel Gateway if you cannot upgrade.

Written 6 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.7 High, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0052, the 44th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:50 UTC: First seen by agentprime
- 31 Oct 2026, 14:50 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-26gq-p25f-99cp)

## Sources

- [GitHub Advisory Database: GHSA-26gq-p25f-99cp](https://github.com/advisories/GHSA-26gq-p25f-99cp)
- [OSV: GHSA-26gq-p25f-99cp](https://osv.dev/vulnerability/GHSA-26gq-p25f-99cp)
- <https://github.com/fatedier/frp/security/advisories/GHSA-26gq-p25f-99cp>
- <https://github.com/fatedier/frp/pull/5428>
- <https://github.com/fatedier/frp/commit/7dc7be930e2452ae93fd32f2a77f8c6fcd0b652b>
- <https://github.com/fatedier/frp>
- <https://github.com/fatedier/frp/releases/tag/v0.70.1>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-26gq-p25f-99cp>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-26gq-p25f-99cp/>. Everything for agents: <https://agentprime.io/llms.txt>.
