# Gogs vulnerable to Stored XSS via Mermaid diagrams

Advisory record · `GHSA-26gq-grmh-6xm6`

- **Identifiers:** `GHSA-26gq-grmh-6xm6` · `GO-2026-4454`
- **State:** Confirmed
- **Severity:** CVSS 7.3 High
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html) · [CWE-1395](https://cwe.mitre.org/data/definitions/1395.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md) · [CWE-1395](https://agentprime.io/advisories/tag/cwe-1395.md)
- **Published:** 6 Feb 2026
- **Updated:** 19 Feb 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 Feb 2026, 19:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `gogs.io/gogs` (Go): affected `<0.13.4`; fixed in `0.13.4`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.3 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 6 Feb 2026. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-26gq-grmh-6xm6](https://github.com/advisories/GHSA-26gq-grmh-6xm6)
- [OSV: GHSA-26gq-grmh-6xm6](https://osv.dev/vulnerability/GHSA-26gq-grmh-6xm6)
- <https://github.com/gogs/gogs/security/advisories/GHSA-26gq-grmh-6xm6>
- <https://github.com/mermaid-js/mermaid/security/advisories/GHSA-7rqq-prvp-x9jh>
- <https://github.com/mermaid-js/mermaid/security/advisories/GHSA-8gwm-58g9-j8pw>
- <https://github.com/gogs/gogs/commit/71a72a72ad1c8cea7940c9d7e4cbdfbc0fc3d401>
- <https://github.com/gogs/gogs>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-26gq-grmh-6xm6>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-26gq-grmh-6xm6/>. Everything for agents: <https://agentprime.io/llms.txt>.
