# Rclone: Unauthenticated options/set allows runtime auth bypass, leading to sensitive operations and command execution

Advisory record · `GHSA-25qr-6mpr-f7qx`

- **Identifiers:** `GHSA-25qr-6mpr-f7qx` · `BIT-rclone-2026-41176` · `CVE-2026-41176` · `GO-2026-4964`
- **State:** Confirmed
- **Severity:** CVSS 9.2 Critical
- **Critical:** Yes: CVSS 9+, CVSS 7+ and EPSS
- **Weakness (CWE):** [CWE-15](https://cwe.mitre.org/data/definitions/15.html) · [CWE-306](https://cwe.mitre.org/data/definitions/306.html)
- **Tags:** [Authentication bypass](https://agentprime.io/advisories/tag/auth-bypass.md) · [CWE-15](https://agentprime.io/advisories/tag/cwe-15.md)
- **Published:** 22 Apr 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 22 Apr 2026, 14:44 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Critical

Critical, because:

- CVSS score 9.2: 9.0 or more.
- CVSS score 9.2 (7.0 or more) and EPSS 0.33 (0.1 or more): a high score and a real chance of exploitation in the next 30 days.

How we decide what’s critical: <https://agentprime.io/advisories/critical.md>

## Affected packages

- `github.com/rclone/rclone` (Go): affected `>=1.45.0, <1.73.5`; fixed in `1.73.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 9.2 Critical, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.33, the 98th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-25qr-6mpr-f7qx)

## Sources

- [GitHub Advisory Database: GHSA-25qr-6mpr-f7qx](https://github.com/advisories/GHSA-25qr-6mpr-f7qx)
- [OSV: GHSA-25qr-6mpr-f7qx](https://osv.dev/vulnerability/GHSA-25qr-6mpr-f7qx)
- <https://github.com/rclone/rclone/security/advisories/GHSA-25qr-6mpr-f7qx>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-41176>
- <https://github.com/rclone/rclone>
- <https://github.com/rclone/rclone/blob/bf55d5e6d37fd86164a87782191f9e1ffcaafa82/fs/rc/config.go>
- <https://github.com/rclone/rclone/blob/bf55d5e6d37fd86164a87782191f9e1ffcaafa82/fs/rc/rcserver/rcserver.go>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-25qr-6mpr-f7qx>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-25qr-6mpr-f7qx/>. Everything for agents: <https://agentprime.io/llms.txt>.
