# Compress/s2: Integer Overflow or Wraparound and Out-of-bounds Write in compress

Advisory record · `GHSA-259r-337f-4rfw`

- **Identifiers:** `GHSA-259r-337f-4rfw` · `CVE-2026-63209` · `GO-2026-5841`
- **State:** Confirmed
- **Severity:** CVSS 7.5 High
- **Critical:** No
- **Weakness (CWE):** [CWE-190](https://cwe.mitre.org/data/definitions/190.html) · [CWE-787](https://cwe.mitre.org/data/definitions/787.html)
- **Tags:** [Memory corruption](https://agentprime.io/advisories/tag/memory-corruption.md)
- **Published:** 20 Oct 2026
- **Updated:** 20 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Oct 2026, 14:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/klauspost/compress` (Go): affected `<1.18.7`; fixed in `1.18.7`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> A signed integer overflow in the Go package github.com/klauspost/compress (the s2 dictionary code, versions up to and including 1.18.6) lets a dictionary supplied to s2.NewDict bypass its repeat-index check. An attacker who can supply dictionary data to an application that later calls Dict.Encode can crash the process with an out-of-bounds memory access. Upgrade to version 1.18.7.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 7.5 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0057, the 47th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:11 UTC: First seen by agentprime
- 31 Oct 2026, 14:11 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-259r-337f-4rfw)

## Sources

- [GitHub Advisory Database: GHSA-259r-337f-4rfw](https://github.com/advisories/GHSA-259r-337f-4rfw)
- [OSV: GHSA-259r-337f-4rfw](https://osv.dev/vulnerability/GHSA-259r-337f-4rfw)
- <https://github.com/klauspost/compress/security/advisories/GHSA-259r-337f-4rfw>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-63209>
- <https://github.com/klauspost/compress/pull/1163>
- <https://github.com/klauspost/compress/commit/539243b8823ee8f03e49969823d57c348c917536>
- <https://github.com/klauspost/compress/commit/8668e357e776d5152ed62f33c17f21b8690664fa>
- <https://github.com/klauspost/compress>
- <https://github.com/klauspost/compress/releases/tag/v1.18.7>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-259r-337f-4rfw>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-259r-337f-4rfw/>. Everything for agents: <https://agentprime.io/llms.txt>.
