# Duplicate Advisory: jQuery Cross Site Scripting vulnerability

Advisory record · `GHSA-257q-pv89-v3xv` · Withdrawn

- **Identifiers:** `GHSA-257q-pv89-v3xv` · `CVE-2020-23064`
- **State:** Withdrawn
- **Severity:** CVSS 6.1 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-79](https://cwe.mitre.org/data/definitions/79.html)
- **Tags:** [Cross-site scripting (XSS)](https://agentprime.io/advisories/tag/xss.md)
- **Published:** 26 Jun 2023
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

**Withdrawn.** The GitHub Advisory Database withdrew this advisory on 15 May 2024. The record stays here, marked withdrawn.

Published by the GitHub Advisory Database at 26 Jun 2023, 21:30 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `jquery` (npm): affected `>=1.0.3, <3.5.0`; fixed in `3.5.0`
- `jQuery` (NuGet): affected `>=1.0.3, <3.5.0`; fixed in `3.5.0`
- `jquery-rails` (RubyGems): affected `<4.4.0`; fixed in `4.4.0`
- `org.webjars.npm:jquery` (Maven): affected `>=1.0.3, <3.5.0`; fixed in `3.5.0`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 6.1 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 26 Jun 2023. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-257q-pv89-v3xv](https://github.com/advisories/GHSA-257q-pv89-v3xv)
- [OSV: GHSA-257q-pv89-v3xv](https://osv.dev/vulnerability/GHSA-257q-pv89-v3xv)
- <https://nvd.nist.gov/vuln/detail/CVE-2020-23064>
- <https://github.com/jquery/jquery/commit/1d61fd9407e6fbe82fe55cb0b938307aa0791f77>
- <https://blog.jquery.com/2020/04/10/jquery-3-5-0-released>
- <https://github.com/advisories/GHSA-jpcq-cgw6-v4j6>
- <https://github.com/jquery/jquery>
- <https://github.com/rails/jquery-rails/blob/master/CHANGELOG.md#410>
- <https://github.com/rails/jquery-rails/blob/master/CHANGELOG.md#440>
- <https://github.com/rails/jquery-rails/blob/v4.3.5/vendor/assets/javascripts/jquery3.js#L5979>
- <https://github.com/rails/jquery-rails/blob/v4.4.0/vendor/assets/javascripts/jquery3.js#L6162>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jquery-rails/CVE-2020-23064.yml>
- <https://security.netapp.com/advisory/ntap-20230725-0003>
- <https://snyk.io/vuln/SNYK-JS-JQUERY-565129>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-257q-pv89-v3xv>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-257q-pv89-v3xv/>. Everything for agents: <https://agentprime.io/llms.txt>.
