# Mattermost Improper Validation of Specified Type of Input vulnerability

Advisory record · `GHSA-2549-xh72-qrpm`

- **Identifiers:** `GHSA-2549-xh72-qrpm` · `CVE-2025-20033` · `GO-2025-3379`
- **State:** Confirmed
- **Severity:** CVSS 4.3 Medium
- **Critical:** No
- **Weakness (CWE):** [CWE-1287](https://cwe.mitre.org/data/definitions/1287.html)
- **Tags:** [CWE-1287](https://agentprime.io/advisories/tag/cwe-1287.md)
- **Published:** 9 Jan 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 9 Jan 2025, 09:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `github.com/mattermost/mattermost/server/v8` (Go): affected `>=9.11.0, <9.11.16 || >=10.0.0, <10.0.4 || >=10.1.0, <10.1.4 || >=10.2.0, <10.2.1 || <8.0.0-20250102081831-64c566a8280b`; fixed in `9.11.16`, `10.0.4`, `10.1.4`, `10.2.1`, `8.0.0-20250102081831-64c566a8280b`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Mattermost server (Go module github.com/mattermost/mattermost/server/v8) versions before 8.0.0-20250102081831-64c566a8280b, 9.11.x through 9.11.15, 10.0.x before 10.0.4, 10.1.x before 10.1.4, and 10.2.0 are affected. An attacker who can create posts can send a post with a specific custom type and properties, which fails to be validated and can deny service to users who hold the sysconsole_read_plugins permission. Upgrade to 8.0.0-20250102081831-64c566a8280b, 9.11.16, 10.0.4, 10.1.4, or 10.2.1, depending on your release line.

Written 1 Nov 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 4.3 Medium, CVSS 3.1: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`, from CNA (Mattermost)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0061, the 49th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:14 UTC: First seen by agentprime
- 31 Oct 2026, 14:14 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-2549-xh72-qrpm)

## Sources

- [GitHub Advisory Database: GHSA-2549-xh72-qrpm](https://github.com/advisories/GHSA-2549-xh72-qrpm)
- [OSV: GHSA-2549-xh72-qrpm](https://osv.dev/vulnerability/GHSA-2549-xh72-qrpm)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-20033>
- <https://github.com/mattermost/mattermost>
- <https://mattermost.com/security-updates>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-2549-xh72-qrpm>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-2549-xh72-qrpm/>. Everything for agents: <https://agentprime.io/llms.txt>.
