# KaTeX: Existing prototype pollution can bypass trust restrictions

Advisory record · `GHSA-238p-pmpm-9mq7`

- **Identifiers:** `GHSA-238p-pmpm-9mq7` · `CVE-2026-103923`
- **State:** Confirmed
- **Severity:** CVSS 2.1 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-807](https://cwe.mitre.org/data/definitions/807.html)
- **Tags:** [CWE-807](https://agentprime.io/advisories/tag/cwe-807.md)
- **Published:** 5 Oct 2026
- **Updated:** 6 Oct 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 5 Oct 2026, 23:41 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `katex` (npm): affected `>=0.11.0, <0.18.2`; fixed in `0.18.2`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 2.1 Low, CVSS 4.0: `CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0030, the 22nd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 13:34 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-238p-pmpm-9mq7)

## Sources

- [GitHub Advisory Database: GHSA-238p-pmpm-9mq7](https://github.com/advisories/GHSA-238p-pmpm-9mq7)
- [OSV: GHSA-238p-pmpm-9mq7](https://osv.dev/vulnerability/GHSA-238p-pmpm-9mq7)
- <https://github.com/KaTeX/KaTeX/security/advisories/GHSA-238p-pmpm-9mq7>
- <https://nvd.nist.gov/vuln/detail/CVE-2026-103923>
- <https://github.com/KaTeX/KaTeX/pull/4260>
- <https://github.com/KaTeX/KaTeX/commit/0adf7e77db6915d991803b29699f82b1ccf8d4f4>
- <https://github.com/KaTeX/KaTeX>
- <https://github.com/KaTeX/KaTeX/releases/tag/v0.18.2>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-238p-pmpm-9mq7>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-238p-pmpm-9mq7/>. Everything for agents: <https://agentprime.io/llms.txt>.
