# webauthn-rs-core/webauthn-authenticator-rs: Origin validation mismatch possible when subdomains are allowed

Advisory record · `GHSA-22w3-693w-x895`

- **Identifiers:** `GHSA-22w3-693w-x895`
- **State:** Confirmed
- **Severity:** CVSS 4.0, no score published
- **Critical:** No
- **Weakness (CWE):** [CWE-1289](https://cwe.mitre.org/data/definitions/1289.html)
- **Tags:** [CWE-1289](https://agentprime.io/advisories/tag/cwe-1289.md)
- **Published:** 6 May 2026
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 6 May 2026, 23:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `webauthn-rs-core` (crates.io): affected `<0.5.5 || >=0.6.0-dev, <0.6.1-dev`; fixed in `0.5.5`, `0.6.1-dev`
- `webauthn-authenticator-rs` (crates.io): affected `>=0.6.0-dev, <0.6.1-dev || <0.5.5`; fixed in `0.6.1-dev`, `0.5.5`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- Score not published, CVSS 4.0: `CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`, from GitHub Advisory Database

- **CISA KEV:** Not listed.
- **EPSS:** No score.

## Timeline

- 31 Oct 2026, 15:17 UTC: First seen by agentprime
- 31 Oct 2026, 15:17 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-22w3-693w-x895)

## Sources

- [GitHub Advisory Database: GHSA-22w3-693w-x895](https://github.com/advisories/GHSA-22w3-693w-x895)
- [OSV: GHSA-22w3-693w-x895](https://osv.dev/vulnerability/GHSA-22w3-693w-x895)
- <https://github.com/kanidm/webauthn-rs/security/advisories/GHSA-22w3-693w-x895>
- <https://github.com/kanidm/webauthn-rs>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-22w3-693w-x895>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-22w3-693w-x895/>. Everything for agents: <https://agentprime.io/llms.txt>.
