# URI allows for userinfo Leakage in URI#join, URI#merge, and URI#+

Advisory record · `GHSA-22h5-pq3x-2gf2`

- **Identifiers:** `GHSA-22h5-pq3x-2gf2` · `CVE-2025-27221`
- **State:** Confirmed
- **Severity:** CVSS 3.2 Low
- **Critical:** No
- **Weakness (CWE):** [CWE-200](https://cwe.mitre.org/data/definitions/200.html) · [CWE-212](https://cwe.mitre.org/data/definitions/212.html)
- **Tags:** [Information disclosure](https://agentprime.io/advisories/tag/info-disclosure.md) · [CWE-212](https://agentprime.io/advisories/tag/cwe-212.md)
- **Published:** 3 Mar 2025
- **Updated:** 10 Sept 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 3 Mar 2025, 22:07 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `uri` (RubyGems): affected `<0.11.3 || >=0.12.0, <0.12.4 || >=0.13.0, <0.13.2 || >=1.0.0, <1.0.3`; fixed in `0.11.3`, `0.12.4`, `0.13.2`, `1.0.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 3.2 Low, CVSS 3.1: `CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:N/A:N`, from CNA (mitre)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0051, the 43rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 15:16 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/GHSA-22h5-pq3x-2gf2)

## Sources

- [GitHub Advisory Database: GHSA-22h5-pq3x-2gf2](https://github.com/advisories/GHSA-22h5-pq3x-2gf2)
- [OSV: GHSA-22h5-pq3x-2gf2](https://osv.dev/vulnerability/GHSA-22h5-pq3x-2gf2)
- <https://nvd.nist.gov/vuln/detail/CVE-2025-27221>
- <https://github.com/ruby/uri/pull/154>
- <https://github.com/ruby/uri/pull/155>
- <https://github.com/ruby/uri/pull/156>
- <https://github.com/ruby/uri/pull/157>
- <https://hackerone.com/reports/2957667>
- <https://github.com/ruby/uri>
- <https://github.com/rubysec/ruby-advisory-db/blob/master/gems/uri/CVE-2025-27221.yml>
- <https://lists.debian.org/debian-lts-announce/2025/03/msg00008.html>
- <https://lists.debian.org/debian-lts-announce/2025/05/msg00015.html>
- <https://www.cve.org/CVERecord?id=CVE-2025-27221>
- <https://www.ruby-lang.org/en/news/2025/02/26/security-advisories>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-22h5-pq3x-2gf2>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-22h5-pq3x-2gf2/>. Everything for agents: <https://agentprime.io/llms.txt>.
