# Lacking Protection against HTTP Request Smuggling in mitmproxy

Advisory record · `GHSA-22gh-3r9q-xf38`

- **Identifiers:** `GHSA-22gh-3r9q-xf38` · `CVE-2021-39214` · `PYSEC-2021-328`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-444](https://cwe.mitre.org/data/definitions/444.html)
- **Tags:** [HTTP request smuggling](https://agentprime.io/advisories/tag/request-smuggling.md)
- **Published:** 20 Sept 2021
- **Updated:** 8 Jul 2026
- **Reviewed by a person:** No

Published by the GitHub Advisory Database at 20 Sept 2021, 19:53 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `mitmproxy` (PyPI): affected `<7.0.3`; fixed in `7.0.3`

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`, from CNA (GitHub_M)

- **CISA KEV:** Not listed.
- **EPSS:** 0.011, the 64th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

This record came from the full history of the GitHub Advisory Database, published 20 Sept 2021. New records show when each source confirmed them.

## Sources

- [GitHub Advisory Database: GHSA-22gh-3r9q-xf38](https://github.com/advisories/GHSA-22gh-3r9q-xf38)
- [OSV: GHSA-22gh-3r9q-xf38](https://osv.dev/vulnerability/GHSA-22gh-3r9q-xf38)
- <https://github.com/mitmproxy/mitmproxy/security/advisories/GHSA-22gh-3r9q-xf38>
- <https://nvd.nist.gov/vuln/detail/CVE-2021-39214>
- <https://github.com/mitmproxy/mitmproxy>
- <https://github.com/pypa/advisory-database/tree/main/vulns/mitmproxy/PYSEC-2021-328.yaml>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/GHSA-22gh-3r9q-xf38>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/GHSA-22gh-3r9q-xf38/>. Everything for agents: <https://agentprime.io/llms.txt>.
