# A remote code execution vulnerability exists within the Field UI module in Drupal core.

Advisory record · `DRUPAL-CORE-2026-014`

- **Identifiers:** `DRUPAL-CORE-2026-014` · `CVE-2026-108097`
- **State:** Confirmed
- **Severity:** CVSS 8.1 High
- **Critical:** No
- **Weakness (CWE):** [CWE-470](https://cwe.mitre.org/data/definitions/470.html)
- **Tags:** [Code injection](https://agentprime.io/advisories/tag/code-injection.md)
- **Published:** 14 Oct 2026
- **Updated:** 14 Oct 2026
- **Reviewed by a person:** No

Published by OSV at 14 Oct 2026, 16:10 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

## Affected packages

- `drupal/core` (Packagist): affected `>=8.9.0, <10.6.19 || >=11.0.0, <11.3.19 || >=11.4.0, <11.4.10 || >=12.0.0-alpha1, <12.0.0-beta2`; fixed in `10.6.19`, `11.3.19`, `11.4.10`, `12.0.0-beta2`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> Drupal core versions 8.9.0 up to but not including 10.6.19, 11.0.0 up to 11.3.19, 11.4.0 up to 11.4.10, and 12.0.0-alpha1 up to 12.0.0-beta2 (Packagist drupal/core) have a remote code execution vulnerability in the Field UI module. The source says core alone is not directly exploitable, but contributed modules and custom code can expose it, and at least one known path does not require authentication. Upgrade to 10.6.19, 11.3.19, 11.4.10, or 12.0.0-beta2. Until then, the source suggests uninstalling the core Field UI module (field_ui) as a mitigation.

Written 31 Oct 2026.

## Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

## Severity and exploitation

- 8.1 High, CVSS 3.1: `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`, from ADP (CISA-ADP)

- **CISA KEV:** Not listed.
- **EPSS:** 0.0057, the 47th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 30 Oct 2026, 03:09 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-108097)
- 30 Oct 2026, 04:18 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-108097)
- 31 Oct 2026, 13:53 UTC: First seen by agentprime
- 31 Oct 2026, 13:53 UTC: [Confirmed by OSV](https://osv.dev/vulnerability/DRUPAL-CORE-2026-014)

## Sources

- [OSV: DRUPAL-CORE-2026-014](https://osv.dev/vulnerability/DRUPAL-CORE-2026-014)
- <https://www.drupal.org/sa-core-2026-014>

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.

## Check whether this affects you

A Match means an installed version is in the affected range above. Most don’t affect the app; agentprime hasn’t analysed this one yet.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), ask your agent to check the project: `check_lockfile` sends a lockfile, `check_packages` a list of installed packages, and both return the Matches and the upgrades that clear them. `get_advisory` returns this record. Setup: <https://agentprime.io/mcp.md>
- In a browser: <https://agentprime.io/check/> reads your lockfile in the browser, never uploading it.
- Whether it touches your code, with file and line: the Claude Code plugin, <https://agentprime.io/plugin.md>
- As JSON: <https://api.agentprime.io/v1/advisories/DRUPAL-CORE-2026-014>, or `POST https://api.agentprime.io/v1/match` with your packages (<https://agentprime.io/api.md>)

---

The web page: <https://agentprime.io/advisories/DRUPAL-CORE-2026-014/>. Everything for agents: <https://agentprime.io/llms.txt>.
