# WebDyne versions from 3.007 before 3.022 for Perl execute .psp files outside the document root via path traversal in the PSGI API route fallback

CVE record · `CVE-2026-78189`

- **Identifiers:** `CVE-2026-78189`
- **State:** Confirmed
- **Severity:** No CVSS score
- **Critical:** No
- **CNA:** CPANSec
- **Weakness (CWE):** [CWE-22](https://cwe.mitre.org/data/definitions/22.html)
- **Tags:** [Path traversal](https://agentprime.io/advisories/tag/path-traversal.md)
- **Published:** 31 Oct 2026
- **Updated:** 31 Oct 2026
- **Reviewed by a person:** No

Published by the CVE Program (CNA: CPANSec) at 31 Oct 2026, 14:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known. This CVE names a vendor and product rather than a package, so the lockfile check doesn’t match it.

## Affected products, as the CNA wrote them

- Vendor: Not given. Product: Not given.
  - affected: `3.007 to before 3.022` (custom)
  - Other versions: unaffected
  - Package name: `WebDyne`
  - Collection: `https://cpan.org/modules`
  - purl: `pkg:cpan/WebDyne`

## Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

> WebDyne versions from 3.007 before 3.022 for Perl are affected. A remote attacker can use path traversal in the PSGI API route fallback to run the embedded Perl in any .psp file the server can read, including files outside the document root. Upgrade WebDyne to version 3.022 or later. The source gives no workaround.

Written 5 Nov 2026.

## Not analysed yet

We haven’t published our own analysis of this CVE. If a person reviews it, this page will say what’s affected and what has to be true for it to matter.

## Severity and exploitation

No source has published a CVSS score for this record yet.

- **CISA KEV:** Not listed.
- **EPSS:** 0.0025, the 16th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

## Timeline

- 31 Oct 2026, 14:33 UTC: [Confirmed by the CVE List](https://www.cve.org/CVERecord?id=CVE-2026-78189)
- 31 Oct 2026, 14:39 UTC: First seen by agentprime
- 31 Oct 2026, 15:16 UTC: [Confirmed by NVD](https://nvd.nist.gov/vuln/detail/CVE-2026-78189)

## Sources

- [CVE List: CVE-2026-78189](https://www.cve.org/CVERecord?id=CVE-2026-78189)
- [NVD: CVE-2026-78189](https://nvd.nist.gov/vuln/detail/CVE-2026-78189)

### References from the CNA

- <https://metacpan.org/release/ASPEER/WebDyne-3.022/changes> (release-notes)

Facts on this page come from the CVE List as the CNA published them, with CVSS from the sources named above, CISA KEV and FIRST EPSS. Vendors, products and versions are shown as the CNA wrote them. We don’t reproduce the CVE’s description.

## Check whether this affects you

This CVE names a vendor and product rather than a package, so the lockfile check doesn’t match it. Compare the affected versions above with what you run.

- With the agentprime MCP server (<https://api.agentprime.io/mcp>), `get_advisory` returns this record and `search_advisories` finds related ones. Setup: <https://agentprime.io/mcp.md>
- As JSON: <https://api.agentprime.io/v1/advisories/CVE-2026-78189>
- Everything that needs attention now: <https://agentprime.io/advisories/critical.md>

---

The web page: <https://agentprime.io/advisories/CVE-2026-78189/>. Everything for agents: <https://agentprime.io/llms.txt>.
